Project

General

Profile

Bug #4185

Duplicated messages on resumption of stream

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
2016-05-19
Due date:
2016-05-31
% Done:

100%

Estimated time:
Database:
n/a
Applicable version:
7.1.0
Source Code Disclaimer:

Description

While using Tigase Mobile Messenger from time to time messages are duplicated during stream resumption - messages which were delivered are delivered once again.


Related issues

Related to Tigase Android Messenger - Support #4184: Duplicated messages on resumption of streamClosed2016-05-192016-07-08

Associated revisions

Revision 9009ae8d (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 3 years ago

Bug #4185 - improved logging of stream resumption

Revision 9c5b4243
Added by Wojciech Kapcia TigaseTeam almost 3 years ago

Merge branch 'release'

  • release: (22 commits) include binaries signing configuration; #3834 Bug #4185 - improved logging of stream resumption #3362 Added Network Setup Guide Align wrapper.conf to tigase.conf, in terms of memory configuration; #4142 Task #4137 - Add counter for disconnections of connections to database use the same version for all modules during release #4062 Readability Fixes for Statistics Descriptions #4062 Fixes to Documentation v7.1.0 patch notes update (thru 4/20/2016) #4062 Server Statistics now documented with new formatting and information. Bug #4120 - fixed issue with duplicated messages in offline store include timestamp inside the file in tigase.stats.CounterDataFileLogger Corrections to Pubsub upgrade documentation and version discrepancies. bump wagon version Small change to Log Guide to better explain fileHandler.pattern adds prefix ("adhoc-command/") to ad-hoc commands listed in statistics; #4062 #4062 Added list and descriptions of statistics fields. #4068 add --ws-allow-unmasked-frames=true to properties guide Issue #4068 and issue #4070 - forcing close of WebSocket connection after receiving unmasked frame from client and corrected order of stream close in rare cases #3792 finish and documentation updates. ...

Conflicts:

modules/documentation/adminguide/asciidoc/index.asciidoc

Revision 4af7ef53 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 3 years ago

Bug #4185 - improved logging of stream resumption

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 3 years ago

  • Related to Support #4184: Duplicated messages on resumption of stream added

#2 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 3 years ago

I was not able to tell what was resend and why. I increased number of data which is logged during resumption of stream to be able to find root cause of this issue when it happens on newer build.

#3 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 3 years ago

  • Due date changed from 2016-05-27 to 2016-05-23
  • Assignee changed from Andrzej Wójcik to Eric Dziewa

%eric I've created build of Tigase XMPP Server with changes required for further analysis of this issue. Could you update tigase.org (t2.tigase.org and t6.tigase.org) to newest versions of Tigase XMPP Server?

When you finish with updating tigase.org installation please reassign this task back to me.

#4 Updated by Eric Dziewa almost 3 years ago

  • Assignee changed from Eric Dziewa to Andrzej Wójcik

Updated to b4222.

#5 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 3 years ago

  • Status changed from New to In Progress

After analysis of logs from new version I support there is an issue with packet counter either on client or server side. To be able to detect where is a problem I increased number of data being logged.

#6 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 3 years ago

  • Due date changed from 2016-05-23 to 2016-05-31

Updated due date - waiting on data which will be gathered from server when issue will occur

#7 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Today, after next logs analysis I identified case in which this issue appears. It is caused by the fact that Jaxmpp2 is not resetting H counter to 0 when stream resumption fails.

%bmalkow is now aware of this and will fix this issue in separate task.

Also available in: Atom PDF