Project

General

Profile

Bug #4398

tigase-jaxmpp2 - Build # 1433 - Failure!

Added by Anonymous over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
2016-07-30
Due date:
2016-08-12
% Done:

100%

Estimated time:
Source Code Disclaimer:

Description

tigase-jaxmpp2 - Build # 1433 - Failure:

Check console output at http://build.tigase.org/jenkins/job/tigase-jaxmpp2/1433/ to view the results.

Changes:

No changes

Started by: Started by timer


[...truncated 1885 lines...]
`docs/javadoc/tigase/jaxmpp/gwt/client/xml/GwtElement.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/xml/GwtElement.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/xml/package-frame.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/xml/package-frame.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/xml/package-use.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/xml/package-use.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/xml/package-tree.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/xml/package-tree.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/xml/class-use' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/xml/class-use'
`docs/javadoc/tigase/jaxmpp/gwt/client/xml/class-use/GwtElement.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/xml/class-use/GwtElement.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/xml/package-summary.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/xml/package-summary.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/JsonSerializationHelper.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/JsonSerializationHelper.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/ConnectionManager.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/ConnectionManager.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/GwtSessionObject.RestoringSessionException.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/GwtSessionObject.RestoringSessionException.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/Presence.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/Presence.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/GWTPresenceStore.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/GWTPresenceStore.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/Jaxmpp.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/Jaxmpp.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/GwtSessionObject.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/GwtSessionObject.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/JsonSerializationHelper.Serializable.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/JsonSerializationHelper.Serializable.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/GwtRosterStore.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/GwtRosterStore.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/JsonSerializationHelper.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/JsonSerializationHelper.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/ConnectionManager.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/ConnectionManager.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/Roster.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/Roster.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/class-use/ConnectionConfiguration.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/class-use/ConnectionConfiguration.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/Roster.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/Roster.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/package-summary.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/package-summary.html'
`docs/javadoc/tigase/jaxmpp/gwt/client/ConnectionConfiguration.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/tigase/jaxmpp/gwt/client/ConnectionConfiguration.html'
`docs/javadoc/package-use.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/package-use.html'
`docs/javadoc/help-doc.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/help-doc.html'
`docs/javadoc/package-tree.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/package-tree.html'
`docs/javadoc/deprecated-list.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/deprecated-list.html'
`docs/javadoc/overview-tree.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/overview-tree.html'
`docs/javadoc/package-list' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/package-list'
`docs/javadoc/allclasses-noframe.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/allclasses-noframe.html'
`docs/javadoc/MessageDeliveryReceiptsExtension.ReceiptReceivedHandler.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/MessageDeliveryReceiptsExtension.ReceiptReceivedHandler.html'
`docs/javadoc/class-use' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/class-use'
`docs/javadoc/class-use/MessageDeliveryReceiptsExtension.ReceiptReceivedHandler.ReceiptReceivedEvent.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/class-use/MessageDeliveryReceiptsExtension.ReceiptReceivedHandler.ReceiptReceivedEvent.html'
`docs/javadoc/class-use/MessageDeliveryReceiptsExtension.ReceiptReceivedHandler.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/class-use/MessageDeliveryReceiptsExtension.ReceiptReceivedHandler.html'
`docs/javadoc/class-use/MessageDeliveryReceiptsExtension.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/class-use/MessageDeliveryReceiptsExtension.html'
`docs/javadoc/allclasses-frame.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/allclasses-frame.html'
`docs/javadoc/serialized-form.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/serialized-form.html'
`docs/javadoc/script.js' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/script.js'
`docs/javadoc/stylesheet.css' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/stylesheet.css'
`docs/javadoc/overview-summary.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/overview-summary.html'
`docs/javadoc/index.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/index.html'
`docs/javadoc/MessageDeliveryReceiptsExtension.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/MessageDeliveryReceiptsExtension.html'
`docs/javadoc/constant-values.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/constant-values.html'
`docs/javadoc/package-summary.html' -> `/home/documentation/tigase-jaxmpp/snapshot/javadoc/package-summary.html'
+ bash -ex /home/jenkins/dist_linker.sh jaxmpp-dist jaxmpp-dist/dist/
+ '[' -z jaxmpp-dist ']'
+ COMPONENT=jaxmpp-dist
+ '[' -z jaxmpp-dist/dist/ ']'
+ SOURCE_DIR=jaxmpp-dist/dist/
+ '[' -z '' ']'
+ NIGHTLIES_DIR=/home/jenkins/nightlies
+ DIST_DIR=/home/jenkins/nightlies/dists
+ echo 'No DIST_DIR given. Using: '\''/home/jenkins/nightlies/dists'\'''
No DIST_DIR given. Using: '/home/jenkins/nightlies/dists'
++ date +%Y-%m-%d
+ NIGHTLY=2016-07-31
+ '[' '!' -e /home/jenkins/nightlies/dists/2016-07-31/ ']'
+ mkdir -p /home/jenkins/nightlies/dists/2016-07-31/
+ for f in '"${DIST_DIR}/${NIGHTLY}/${COMPONENT}"*'
+ '[' -e '/home/jenkins/nightlies/dists/2016-07-31/jaxmpp-dist*' ']'
+ cp -v 'jaxmpp-dist/dist//jaxmpp-dist-*' /home/jenkins/nightlies/dists/2016-07-31/
cp: cannot stat `jaxmpp-dist/dist//jaxmpp-dist-*': No such file or directory
Build step 'Execute shell' marked build as failure
Started calculate disk usage of build
Finished Calculation of disk usage of build in 0 seconds
Started calculate disk usage of workspace
Finished Calculation of disk usage of workspace in 0 seconds
Notifying upstream projects of job completion
Email was triggered for: Failure - 1st
Email was triggered for: Failure - Any
Trigger Failure - Any was overridden by another trigger and will not send an email.
Trigger Failure - Still was overridden by another trigger and will not send an email.
Sending email for trigger: Failure - 1st

Associated revisions

Revision 447bd41f (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 2 years ago

Bug #4398 - remove used JDK8 specific features which are not supported by GWT

History

#1 Updated by Wojciech Kapcia TigaseTeam over 2 years ago

  • Due date set to 2016-08-12
  • Assignee set to Bartosz Malkowski

This exact one was caused by the jarsigner/tsa problem, BUT - since 2061-07-26 builds are marked as unstable due to failing tests:

http://build.tigase.org/jenkins/job/tigase-jaxmpp2/1428/testReport/

Please take a look at it or assign to %andrzej.wojcik if appropriate.

#2 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 2 years ago

  • Assignee changed from Bartosz Malkowski to Andrzej Wójcik

I just looked at this test report and will fix it - I introduced "default" method to element interface which is not support by GWT - even in newest versions.

#3 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

I fixed this issue by removal of default method from Element interface which is not supported by GWT.

I also needed to remove closures used in MAM module as it also could cause issue with compilation using GWT.

At this point I think that GWT is almost dead - over 2 years after initial release of JDK8 still no support for some features :/

#4 Updated by Wojciech Kapcia TigaseTeam over 2 years ago

Andrzej Wójcik wrote:

At this point I think that GWT is almost dead - over 2 years after initial release of JDK8 still no support for some features :/

I've read somewhere, that initially version 2.8 was scheduled almost over a year ago, but due to other dependencies (mentions Guava library) it was pushed and "it should be released soon", but...

#5 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 2 years ago

This is why i used "almost dead"

Also available in: Atom PDF