Project

General

Profile

Feature #4732

Add support for XEP-0313: Messege Archive Management

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
2016-11-19
Due date:
% Done:

100%

Estimated time:
Source Code Disclaimer:

Description

I think it may be good idea to add support for "MAM:http://xmpp.org/extensions/xep-0313.html to MUC. It was already added for Message Archiving component to make it easier to retrieve older messages. MAM can be used with MUC for same reasons. After we add this implementation we would be able to use same protocol to communicate with both components.


Related issues

Related to Tigase Message Archiving - Feature #4242: Add support for XEP-0313: Messege Archive ManagementClosed2016-06-152016-07-25

Related to Tigase PubSub - Task #4733: Add support for XEP-0313: Messege Archive ManagementClosed2016-11-19

Associated revisions

Revision 89e4343d (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

Task #4732 - added support for XEP-0313: Message Archive Management to MUC history provider

Revision a0c8797f (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

Task #4732 - updated MySQL JDBC driver due to lack of support for precise timestamps

Revision ed9e7e23 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

Task #4732 - minor fix in MessageArchiveManagementModule

Revision 8309684d (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

Task #4732 - added test case for MAM in MUC

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam about 2 years ago

  • Related to Feature #4242: Add support for XEP-0313: Messege Archive Management added

#2 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam about 2 years ago

  • Related to Task #4733: Add support for XEP-0313: Messege Archive Management added

#3 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Feature implemented and test cases added to TTS-NG project and confirmed that support for MAM works properly in MUC.

#4 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

  • Status changed from Resolved to Closed

#5 Avatar?id=6023&size=24x24 Updated by Artur Hefczyc TigaseTeam almost 2 years ago

  • Target version deleted (tigase-server-8.0.0)

Also available in: Atom PDF