Project

General

Profile

Bug #5394

Loading main Derby schema throws exception

Added by Wojciech Kapcia TigaseTeam almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
Due date:
2017-04-28
% Done:

100%

Estimated time:
Database:
n/a
Applicable version:
git/master
Source Code Disclaimer:

Description

2017-04-19 18:39:45.785 [main]             DBSchemaLoader.validateDBSchema()       FINEST:   Executing query: call Tig_OfflineMessages_Migrate()
abr 19, 2017 6:39:45 PM tigase.db.derby.MsgRepositoryStoredProcedures migrateFromOldSchema
ADVERTENCIA: Migration of data failed
java.sql.SQLSyntaxErrorException: Table/View 'MSG_HISTORY' does not exist.
    at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
    at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
    at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
    at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
    at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
    at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
    at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
    at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
    at tigase.db.derby.MsgRepositoryStoredProcedures.migrateFromOldSchema(MsgRepositoryStoredProcedures.java:56)
    at org.apache.derby.exe.ac2e31c0abx015bx8828x2761x00000e61d1c02.g0(Unknown Source)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.apache.derby.impl.services.reflect.ReflectMethod.invoke(Unknown Source)
    at org.apache.derby.impl.sql.execute.CallStatementResultSet.open(Unknown Source)
    at org.apache.derby.impl.sql.GenericPreparedStatement.executeStmt(Unknown Source)
    at org.apache.derby.impl.sql.GenericPreparedStatement.execute(Unknown Source)
    at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(Unknown Source)
    at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
    at org.apache.derby.impl.jdbc.EmbedStatement.execute(Unknown Source)
    at tigase.db.util.DBSchemaLoader.validateDBSchema(DBSchemaLoader.java:573)
    at tigase.db.util.DBSchemaLoader$Tasks$3.execute(DBSchemaLoader.java:946)
    at tigase.db.util.DBSchemaLoader.execute(DBSchemaLoader.java:277)
    at tigase.db.util.DBSchemaLoader.main(DBSchemaLoader.java:255)
Caused by: ERROR 42X05: Table/View 'MSG_HISTORY' does not exist.
    at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
    at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
    at org.apache.derby.impl.sql.compile.FromBaseTable.bindTableDescriptor(Unknown Source)
    at org.apache.derby.impl.sql.compile.FromBaseTable.bindNonVTITables(Unknown Source)
    at org.apache.derby.impl.sql.compile.TableOperatorNode.bindNonVTITables(Unknown Source)
    at org.apache.derby.impl.sql.compile.TableOperatorNode.bindNonVTITables(Unknown Source)
    at org.apache.derby.impl.sql.compile.FromList.bindTables(Unknown Source)
    at org.apache.derby.impl.sql.compile.SelectNode.bindNonVTITables(Unknown Source)
    at org.apache.derby.impl.sql.compile.DMLStatementNode.bindTables(Unknown Source)
    at org.apache.derby.impl.sql.compile.DMLStatementNode.bindResultSetsWithTables(Unknown Source)
    at org.apache.derby.impl.sql.compile.InsertNode.bindStatement(Unknown Source)
    at org.apache.derby.impl.sql.GenericStatement.prepMinion(Unknown Source)
    at org.apache.derby.impl.sql.GenericStatement.prepare(Unknown Source)
    at org.apache.derby.impl.sql.conn.GenericLanguageConnectionContext.prepareInternalStatement(Unknown Source)
    ... 19 more

Associated revisions

Revision 96170b1f (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

#5394: fixed issue with upgrade being fired for new DerbyDB databases

squash! #5394: fixed issue with upgrade being fired for new DerbyDB databases

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

  • Status changed from New to In QA
  • Assignee changed from Andrzej Wójcik to Wojciech Kapcia
  • % Done changed from 0 to 100

I've fixed issue with wrong query detecting whether it is clean install or upgrade.

#2 Updated by Wojciech Kapcia TigaseTeam almost 2 years ago

  • Status changed from In QA to Closed

Also available in: Atom PDF