Project

General

Profile

Bug #5421

WebSocket connection can enter infinite loop

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Source Code Disclaimer:

Description

It is possible that WebSocket connection in Jaxmpp-J2SE may enter infinite loop.


Related issues

Related to Tigase TTS-NG - Feature #5207: Automatic creation of required accounts/valuesClosed2017-05-12

Associated revisions

Revision 3e270d76 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#5421: Fixed issue with handling PONG WebSocket frames with payload

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

  • Related to Feature #5207: Automatic creation of required accounts/values added

#2 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

The issue was caused by WebSocket PONG frame with a payload being sent by a server in response to PING packet being sent by a client in TTS-NG test.

Also available in: Atom PDF