Project

General

Profile

Bug #5428

domains-per-user-limit in vhost-man doesn't work

Added by Wojciech Kapcia TigaseTeam almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Database:
n/a
Applicable version:
git/master
Source Code Disclaimer:

Description

Despite having

'vhost-man' {
    'domains-per-user-limit' = 100000
}

It results in

<iq to="admin@test-d/def-user-resource" id="aacba" from="vhost-man@test-d" type="result"><command status="completed" node="comp-repo-item-add" xmlns="http://jabber.org/protocol/commands"><x xmlns="jabber:x:data" type="result"><field var="Error" type="fixed"><value>The item did not pass validation checking.</value></field><field var="Note" type="fixed"><value>   </value></field><field var="Warning" type="fixed"><value>Maximum number of domains exceeded for the user! Current number is: 25</value></field></x></command></iq>

Relevant 7.1.0 option

vhost-man/domains-per-user-limit[I]=100000

Associated revisions

Revision 5e54642d (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

#5428: fixed issue with domains-per-user-limit not being set

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

  • Status changed from New to In QA
  • Assignee changed from Andrzej Wójcik to Wojciech Kapcia

I fixed this issue. It was caused by missing alias property in @ConfigField annotation at field of VHostJDBCRepository

#2 Updated by Wojciech Kapcia TigaseTeam almost 2 years ago

  • Status changed from In QA to Closed
  • % Done changed from 0 to 100

Works now!

Prepare:  XEP-0077 - In-Band Registration, register  ... success,  Total: 219ms
VHost 1:  XEP-0199: XMPP Ping to virtual domain 'test-domain' on the server  ... success,  Total: 34ms
VHost 2:  Reloading VHosts from non-admin account, expecting error message  ... success,  Total: 58ms
VHost 3:  Updating VHost from non-admin account, expecting error message  ... success,  Total: 243ms
VHost 4:  Removing VHost from non-admin account, expecting error message  ... success,  Total: 82ms
VHost 5:  Reloading VHosts from admin account...  ... success,  Total: 63ms
VHost 6:  XEP-0199: XMPP Ping to virtual domain 'vhost-1' which is not on the server, expecting error response  ... success,  Total: 51ms
VHost 7:  Adding VHost 'vhost-1' from admin account  ... success,  Total: 142ms
VHost 8:  XEP-0199: XMPP Ping to virtual domain 'vhost-1' on the server  ... success,  Total: 29ms
VHost 9:  Removing VHost 'vhost-1' from admin account  ... success,  Total: 52ms
VHost 10:  XEP-0199: XMPP Ping to virtual domain 'vhost-1' which is not on the server, expecting error response  ... success,  Total: 32ms
VHost 11:  XEP-0199: XMPP Ping 200 non-existen vhosts on the server, expecting error responses  ... success,  Total: 765ms, Average: 3ms, Loop: 200, OK: 200
VHost 12:  Adding 200 virtual hosts from admin account  ... success,  Total: 1709ms, Average: 8ms, Loop: 200, OK: 200
VHost 13:  XEP-0199: XMPP Ping all 200 virtual hosts on the server  ... success,  Total: 234ms, Average: 1ms, Loop: 200, OK: 200
VHost 14:  Reloading all VHosts from admin account...  ... success,  Total: 59ms
VHost 15:  Removing 200 VHosts from admin account  ... success,  Total: 1179ms, Average: 5ms, Loop: 200, OK: 200
VHost 16:  XEP-0199: XMPP Ping 200 non-existen vhosts on the server, expecting error responses  ... success,  Total: 353ms, Average: 1ms, Loop: 200, OK: 200
VHost 17:  Reloading all VHosts from admin account...  ... success,  Total: 31ms
Test finished after: 00:00:06
/tigase-console.log

Also available in: Atom PDF