Project

General

Profile

Bug #5669

Task #5582: TTS-NG failing tests

Testing state of JaXMPP instance… test fails

Added by Wojciech Kapcia TigaseTeam over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Start date:
Due date:
2017-06-16
% Done:

100%

Estimated time:

Description

Testing state of JaXMPP instance after issues with connection or authentication timeout - #4378 it fails for all databases.

Associated revisions

Revision 945f8ce9 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#5669: improvements to Jaxmpp reconnection test case

Revision f729a090 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#5669: removed firing ErrorEvent by connectors if exception is thrown in start() method within the same thread

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

  • Status changed from New to In Progress

#2 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

  • Status changed from In Progress to In QA
  • Assignee changed from Andrzej Wójcik to Wojciech Kapcia
  • % Done changed from 0 to 100

It was caused by a bug in Jaxmpp which fired ErrorEvent on a separate thread even though an exception was being thrown by Connector and resulted in handlers of ErrorEvent being called after login() method was exited.

The issue will be fixed with a new build of Jaxmpp.

#3 Updated by Wojciech Kapcia TigaseTeam over 1 year ago

  • Status changed from In QA to Closed

Also available in: Atom PDF