Project

General

Profile

Bug #5693

Disable Offline Messaging in 7.2

Added by Eric Dziewa over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Database:
n/a
Applicable version:
7.2.0
Source Code Disclaimer:

Description

The converter gave me these lines but messages are being saved to new table tig_offline_messages.

'sess-man' {
    amp {
        'msg-offline' = 'false'
    }
    strategy (class: tigase.server.cluster.strategy.OnlineUsersCachingStrategy) {}
}

Associated revisions

Revision dfd3763f (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#5693: fixed issues related to configuration of SessionManager processors

Revision b52965b8 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#5693: fixed issues related to configuration of SessionManager processors

Revision 8197707d (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#5693: fixed issues related to configuration of SessionManager processors

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

  • Status changed from New to In Progress

#2 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

  • Status changed from In Progress to In QA
  • Assignee changed from Andrzej Wójcik to Eric Dziewa
  • % Done changed from 0 to 100

This bug was caused by two separate issues:

  1. Converter should return different configuration in DSL

I've fixed it in converter

  1. Issue with configuration of SessionManager processors

Not all fields in processors where properly annotated. I reviewed all processors and updated implementations, so that configuration fields/properties are properly annotated.

Next snapshot build will contain fixes for both issues.

#3 Updated by Eric Dziewa over 1 year ago

  • Status changed from In QA to Closed

Works nice.

Also available in: Atom PDF