Project

General

Profile

Bug #5831

OOM after startup

Added by Wojciech Kapcia TigaseTeam almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Database:
n/a
Applicable version:
git/master
Source Code Disclaimer:

Description

On commit: 498191e6b8502095d5d1cf08fdf9606f9bc1e718 after a couple of minutes after starting up the server I get following

2017-07-19 10:57:31.156 [main]             ThreadExceptionHandler.uncaughtException()  SEVERE: Uncaught thread: "main" exception
java.lang.OutOfMemoryError: unable to create new native thread
    at java.lang.Thread.start0(Native Method)
    at java.lang.Thread.start(Thread.java:717)
    at java.util.Timer.<init>(Timer.java:176)
    at java.util.Timer.<init>(Timer.java:146)
    at tigase.xmpp.impl.TokenBucketPool.<init>(TokenBucketPool.java:15)
    at sun.reflect.GeneratedConstructorAccessor74.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at java.lang.Class.newInstance(Class.java:442)
    at tigase.component.DSLBeanConfigurator.lambda$dumpConfiguration$1(DSLBeanConfigurator.java:209)
    at tigase.kernel.core.Kernel.getInstanceIfExistsOr(Kernel.java:413)
    at tigase.component.DSLBeanConfigurator.dumpConfiguration(DSLBeanConfigurator.java:207)
    at tigase.component.DSLBeanConfigurator.dumpConfiguration(DSLBeanConfigurator.java:204)
    at tigase.component.DSLBeanConfigurator.dumpConfiguration(DSLBeanConfigurator.java:204)

…
    at tigase.component.DSLBeanConfigurator.dumpConfiguration(DSLBeanConfigurator.java:204)
    at tigase.component.DSLBeanConfigurator.dumpConfiguration(DSLBeanConfigurator.java:204)
    at tigase.component.DSLBeanConfigurator.dumpConfiguration(DSLBeanConfigurator.java:204)
    at tigase.component.DSLBeanConfigurator.dumpConfiguration(DSLBeanConfigurator.java:181)
    at tigase.server.Bootstrap.start(Bootstrap.java:173)
    at tigase.server.XMPPServer.start(XMPPServer.java:136)
    at tigase.server.XMPPServer.main(XMPPServer.java:117)

Associated revisions

Revision 014fb3ea (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

#5831: adjustments of TokenBucketPool to better fit into Kernel managed environment

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 2 years ago

  • Status changed from New to In QA
  • Assignee changed from Andrzej Wójcik to Wojciech Kapcia
  • % Done changed from 0 to 100

I was not able to replicate this issue. I've identified a usage of Timer in TokenBucketPool which should be done differently in Tigase Kernel based environment and I've changed this code.

#2 Updated by Wojciech Kapcia TigaseTeam over 1 year ago

  • Status changed from In QA to Closed

Can't reproduce anymore, closing.

Also available in: Atom PDF