Project

General

Profile

Task #6206

Better separation of utils and xmltools

Added by Wojciech Kapcia TigaseTeam over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Database:
n/a

Description

Currently tigase-utils and tigase-xmltools are inlined to tigase-server (reason was that OSGi prohibits packages across various jar) and it would be good to tackle "split packages" problem as new java9/jigsaw modules also forbid 'split packages' in modules.

%kobit yesno?


Related issues

Related to Tigase XMPP Server - Bug #6299: XMPP Server crash on startupClosed

Related to Tigase XMLTools - Bug #6430: Wrong version is reportedClosed

Associated revisions

Revision aff9d1de (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: moving tigase.annotations package to tigase.xml.annotations and bumpting version to 4.0.0 to reflect change in API

Revision c5d8a6cc (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: adjusted to API changes (rename of packages)

Revision 984412d2 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: adjusted to API changes (rename of packages)

Revision 2a30924a (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: adjusted to API changes (rename of packages)

Revision c78fa991 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: adjusted to API changes (rename of packages)

Revision b9e13c2a (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: adjusted to API changes (rename of packages)

Revision c968634a (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: adjusted to API changes (rename of packages)

Revision c889188a (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: updated depdendencies versions

Revision 102c142d (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: moved classes from tigase.utll to subpackages and adjusted to changes done in tigase-utils and tigase-xmltools

Revision 0598f218 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

#6206: renamed tigase.xmpp package to tigase.xmpp.jid and moved a few classes from tigase.util to new subpackages

Revision 18f74b45 (diff)
Added by Wojciech Kapcia TigaseTeam over 1 year ago

#6206 adjusting imports in benchmark module

Revision 3a2584af (diff)
Added by Wojciech Kapcia TigaseTeam over 1 year ago

#6206 update PriorityQueueStrict package

Revision 30863ff3 (diff)
Added by Wojciech Kapcia TigaseTeam over 1 year ago

#6206 update PriorityQueueStrict package

Revision 725395de (diff)
Added by Wojciech Kapcia TigaseTeam over 1 year ago

#6206 add conversion of the PriorityQueueStrict package due to changes in location, add unittest, adjust documentaiton

Revision 709d4d37 (diff)
Added by Wojciech Kapcia TigaseTeam about 1 year ago

#6206: update dependencies

Revision 0dc76878 (diff)
Added by Wojciech Kapcia TigaseTeam about 1 year ago

#6206: update dependencies and adjust API to changed paths

Revision dc8f29f8 (diff)
Added by W Administrator 3 months ago

#6206 update LogFormatter package in configurations

History

#1 Avatar?id=6023&size=24x24 Updated by Artur Hefczyc TigaseTeam over 1 year ago

yes

#2 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

%kobit If I'm correct this would require changing package names. As a result, it will break API, so maybe it should be done in 8.0?

#3 Avatar?id=6023&size=24x24 Updated by Artur Hefczyc TigaseTeam over 1 year ago

Andrzej Wójcik wrote:

%kobit If I'm correct this would require changing package names. As a result, it will break API, so maybe it should be done in 8.0?

Definitely yes

#4 Avatar?id=6023&size=24x24 Updated by Artur Hefczyc TigaseTeam over 1 year ago

  • Target version changed from tigase-server-8.1.0 to tigase-server-8.0.0

#5 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

  • Status changed from New to In Progress
  • Assignee changed from Wojciech Kapcia to Andrzej Wójcik

#6 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

  • % Done changed from 0 to 90

#7 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 1 year ago

  • Status changed from In Progress to In QA
  • Assignee changed from Andrzej Wójcik to Wojciech Kapcia
  • % Done changed from 90 to 100

From my perspective, all works as expected.

#8 Updated by Wojciech Kapcia TigaseTeam over 1 year ago

  • Related to Bug #6299: XMPP Server crash on startup added

#9 Updated by Wojciech Kapcia TigaseTeam over 1 year ago

  • Status changed from In QA to In Progress

Issue with @PriorityQueueStrict@:

2017-11-04 04:14:38.015 [main]             AbstractBeanConfigurator.configure()    WARNING:  Can't prepare value of property 'priorityQueueClass' of bean 'message-router': 'tigase.util.PriorityQueueStrict'
java.lang.RuntimeException: Cannot convert to class java.lang.Class
    at tigase.kernel.DefaultTypesConverter.convert(DefaultTypesConverter.java:124)
    at tigase.kernel.beans.config.AbstractBeanConfigurator.configure(AbstractBeanConfigurator.java:301)
    at tigase.component.DSLBeanConfiguratorWithBackwardCompatibility.configure(DSLBeanConfiguratorWithBackwardCompatibility.java:49)
    at tigase.kernel.beans.config.AbstractBeanConfigurator.configure(AbstractBeanConfigurator.java:360)
    at tigase.kernel.core.Kernel.initBean(Kernel.java:123)
    at tigase.kernel.core.Kernel.getInstance(Kernel.java:286)
    at tigase.server.Bootstrap.start(Bootstrap.java:162)
    at tigase.server.XMPPServer.start(XMPPServer.java:193)
    at tigase.server.XMPPServer.main(XMPPServer.java:147)
Caused by: java.lang.ClassNotFoundException: tigase.util.PriorityQueueStrict
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    at tigase.osgi.ModulesManagerImpl.forName(ModulesManagerImpl.java:105)
    at tigase.kernel.DefaultTypesConverter.convert(DefaultTypesConverter.java:122)
    at tigase.kernel.beans.config.AbstractBeanConfigurator.configure(AbstractBeanConfigurator.java:301)
    at tigase.component.DSLBeanConfiguratorWithBackwardCompatibility.configure(DSLBeanConfiguratorWithBackwardCompatibility.java:49)
    at tigase.kernel.beans.config.AbstractBeanConfigurator.configure(AbstractBeanConfigurator.java:360)
    at tigase.kernel.core.Kernel.initBean(Kernel.java:123)
    at tigase.kernel.core.Kernel.getInstance(Kernel.java:286)
    at tigase.server.Bootstrap.start(Bootstrap.java:162)
    at tigase.server.XMPPServer.start(XMPPServer.java:193)
    at tigase.server.XMPPServer.main(XMPPServer.java:147)

#10 Updated by Wojciech Kapcia TigaseTeam over 1 year ago

  • Status changed from In Progress to In QA

While working on #5379 I noticed that all tests started to fail when the change was made. It was due to using old path to the PriorityQueueStrict class. I've adjusted the converted to handle the change.

Let's see next tests results.

#11 Updated by Wojciech Kapcia TigaseTeam about 1 year ago

  • Related to Bug #6430: Wrong version is reported added

#12 Updated by Wojciech Kapcia TigaseTeam about 1 year ago

  • Status changed from In QA to Closed

Some repositories were not adjusted, and jenkins didn't catch the change as old dependencies were used (for example 3.6.0-SNAPSHOT) which still contained old packages paths.

I have:

  • manually removed changed version as it seems that archiva has troubles respecting "retain only x days" and "retain only x artifacts" (or better yet - it will retain x SNAPSHOT artifacts even though they exceed the defined time; there is another option "remove released artifacts" but, given those versions haven't been released those artifacts haven't been removed).

  • wen't over the project and:

    • tigase-licence - updated dependencies and API
    • tigase-pubsub - removed dependency on tigase-utils and removed two test scripts as they weren't used anymore

Also available in: Atom PDF