Project

General

Profile

Bug #8061

Make sure that RepositoryItems are correctly stored in repository

Added by Wojciech Kapcia TigaseTeam 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Database:
n/a
Applicable version:
7.1.3
Source Code Disclaimer:

Description

Currently socket type is not correctly stored in the repository.


Related issues

Related to Tigase XMPP Server - Bug #3402: VHosts are not stored to repositoryRejected2015-08-17

Related to Tigase XMPP Server - Feature #7922: RepoItems handling changesClosed

Associated revisions

Revision ce8ab2e5 (diff)
Added by W Administrator 4 months ago

#8061 Add script to force persisting repository items to database

Revision 30b4cac9 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam 3 months ago

#8061: added adhoc to persist API keys configuration to the database

Revision fbc23d33 (diff)
Added by W Administrator 3 months ago

#8061 update tigase-http-api dependency version to include fix; move CompRepoItemPersist script to "Configuration" group

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam 4 months ago

  • Status changed from New to Rejected
  • Assignee changed from Andrzej Wójcik to Wojciech Kapcia
  • % Done changed from 0 to 100

It looks like socket type is properly stored in the repository in version 7.1.3 but it was not in version 8.0.0. As socket type option was added 8 months ago in version 7.1.3, I suppose it was not merged properly to version 8.0.0 which caused an issue, but after recent changes and fixes, all is ok now.

#2 Updated by Wojciech Kapcia TigaseTeam 4 months ago

  • Related to Bug #3402: VHosts are not stored to repository added

#3 Updated by Wojciech Kapcia TigaseTeam 4 months ago

  • Subject changed from Make sure that socket type is correctly stored in repository to Make sure that RepositoryItems are correctly stored in repository
  • Status changed from Rejected to New

Actually the problem is slightly different - init.properties-only configuration is not stored in repository if never updated via ad-hoc/admin UI.

#4 Updated by Wojciech Kapcia TigaseTeam 4 months ago

  • Status changed from New to Closed

I included a small ad-hoc script Persist item configuration to force storing items to repository. Thus, after upgrading to 8.0.0 items will still be correctly available.

#5 Updated by Wojciech Kapcia TigaseTeam 4 months ago

  • Status changed from Closed to In Progress
  • % Done changed from 100 to 70

Add src/main/groovy/tigase/http/modules/rest/ApiKeyPersistCmd.java in http-api

#6 Updated by Wojciech Kapcia TigaseTeam 3 months ago

  • Assignee changed from Wojciech Kapcia to Andrzej Wójcik

Please add Persist item configuration for api-keys in http-api.

#7 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam 3 months ago

  • Status changed from In Progress to In QA
  • Assignee changed from Andrzej Wójcik to Wojciech Kapcia
  • % Done changed from 70 to 100

I've added adhoc script named "Persist API keys items configuration" to the HTTP API component. As I checked it works fine, but it would be good to double check that.

#9 Updated by Wojciech Kapcia TigaseTeam 3 months ago

#10 Updated by Wojciech Kapcia TigaseTeam 3 months ago

  • Status changed from In QA to Closed

Works good. I bumped http-api dependency in tigase-server:stable to include your fix.

Also available in: Atom PDF